View source | Discuss this page | Page history | Printable version   
Main Page
Upload file
What links here
Recent changes

PDF Books
Add page
Show collection (0 pages)
Collections help


How to setup Eclipse IDE


Preparing development environment

First of all you need to install and configure different components of the Openbravo ERP environment as it's described in Custom Installation guide. In order to comply to development requirements some of those components have to be additionally adjusted according to Development Stack Setup.

Bulbgraph.png   Double check that you have read and followed the Development Stack Setup article

After completing all of the steps in the aforementioned guides, please make sure that:

Download source code

The source code can be checked out using any Mercurial client. There is no any restrictions on the read access so you wouldn't need any credentials to access the repository. The detailed procedure of the source code check out is described in Mercurial Manual for Openbravo Developers. As it's explained in the guide it's normally considered as a good practice to have a pristine clone and working one, so we would strongly encourage you to follow that 'rule'. It is also highly advisable to clone the repository into a destination directory which is outside of Eclipse workspace.

If you want to build the latest stable release:

$ hg clone openbravo
$ cd openbravo
$ hg up 3.0PR16Q3.2

For Openbravo developers, you should work with the pi repository:

hg clone
$ cd pi

Openbravo installation

The Openbravo ERP installation is performed in several steps.

Configure the properties

So, first of all you have to configure the Openbravo ERP by specifying some general properties, e.g. Tomcat installation directory, database connection details, etc. This can (and in fact must) be done via a console application which has to be compile first. For that, go to the directory with the working clone of the repository and execute:

ant setup

The invocation of this ant target will compile and execute automatically a console application.By going through the console application provide all requested information and at the end, select Accept to apply the changes and close the application.

Note: More about setup ant task can be found at

As a result of these actions a new file, containing specified settings, will be created in config subdirectory.

Bulbgraph.png   While going through the console application, DO NOT change the default context name which is openbravo. This guide assumes that it will be left this way.

More about the properties can be found at Now the Openbravo ERP is ready to be installed.

Install from sources

In order to install the Openbravo ERP three main procedures have to be accomplished:

All this is done by invoking from the root of the working clone (XXX\opensource\openbravo\erp\devel\main\).

ant install.source

This process can take quite long time (up to 25 min) depending on hardware configuration. It's always a good idea to redirect the output of the task execution to a log file which then can be analyzed or sent to the support team in case of problems. After the task has completed the log should not contain any error or exception massages as well as it should have BUILD SUCCESSFUL message at the end of the file. (if you are under Linux use grep command to check whether the file contains any exceptions). After successful installation the next step can be taken - importing to Eclipse IDE.

Bulbgraph.png   You can save the install.source log using tee in Linux or mtee in Windows

Problems running install.source

If you find problems running install.source, check the Installation/Troubleshooting article

Import into Eclipse IDE

Launch Eclipse.

Bulbgraph.png   After Eclipse has started go to Project menu and disable Build Automatically option there.

Now 4 projects need to be imported in the workspace (by menu File=>Import and then General=>Existing Projects into Workspace). Here they are:

openbravo        XXX\opensource\openbravo\erp\devel\main\
OpenbravoCore    XXX\opensource\openbravo\erp\devel\main\src-core
OpenbravoTrl     XXX\opensource\openbravo\erp\devel\main\src-trl
OpenbravoWAD     XXX\opensource\openbravo\erp\devel\main\src-wad

Create the Tomcat Server

Then open Servers view and create a new instance of Tomcat server:


While going through the wizard select openbravo and add it to configured resources. Then click "Finish". The created instance should appear in the view. Double click on it to change its settings in the form depicted on the picture below:


Change VM arguments settings

 -server -Djava.awt.headless=true -Xms384M -Xmx1536M -XX:MaxPermSize=256M 

After changing all, save your server configuration (press Ctrl+S).

Renaming server

When creating a new server, by default is is named "Tomcat v7.0 Server at localhost". This name can be changed to something custom, both at creation time or later by editing it in server window.

In this case, it is necessary to bind the Server Library with the actual server. To do so:

Eclipse bind tomcat.png

Import Preferences

The next step is to set the standard preferences used in the development of Openbravo.


Once finished, select all the projects, refresh them, and rebuild them (right click on one or more projects and you will find the Refresh and the Rebuild options). You should get warnings, but not errors.

Bulbgraph.png   Latest Eclipse releases starting from Mars do different Java formatting than previous ones. In order to maintain the same formatting, it is necessary to install old formatter as plugin. Read here more details on how to do it.

Launch from Eclipse

Now start the Tomcat server by right-clicking on the server instance in the Servers view and choosing Start option in the popup menu. Wait until the server is started (can take up to 2 minutes) and visit http://localhost:8080/openbravo/ in your internet browser. If everything was configured and installed properly you will get to the Openbravo ERP log in page. Use these credentials to log in:

both are case sensitive.

That's it, the installation is over and you're ready to start developing.

Bulbgraph.png   If your system has enough resources (memory/processor) then you can try enabling the Build Automatically option in the Project menu. Enabling it will give you direct feedback while developing.

Upgrading old workspaces to >=PR17Q1

Starting from PR17Q1, the minimum System Requirements for Openbravo were increased to Java 7 and Tomcat 7. For worskpaces created in older versions, some upgrade might be required.

Once updated to a newer version on a recent stack, it will be automatically allowed to write Java 7 compliant code.

If Tomcat 6 was used, the server needs to be removed and a new Tomcat >=7 needs to be created, after it, a rebuild will be required, see how here.

Warn-icon.png   If you are developing modules compatible with older Openbravo versions or creating code to be backported to those, the code needs to be still compatible with Java 6. In these cases it is recommended to use workspace with older (previous to 3.0PR17Q1) Openbravo sources.

Retrieved from ""

This page has been accessed 90,365 times. This page was last modified on 17 October 2016, at 08:47. Content is available under Creative Commons Attribution-ShareAlike 2.5 Spain License.